1C Предприятие. БСП. Разработка и регистрация внешней дополнительной обработки

01.07.2019 08:33:00   Вася Котов (ayv73@bk.ru)    1669

Нравится 0 Не нравится 0

1C Предприятие. БСП. Дополнительные отчеты и обработки. Разработка и регистрация внешней дополнительной обработки за 10 минут. Работа по расписанию в фоновом режиме.

Функция СведенияОВнешнейОбработке() Экспорт

ПараметрыРегистрации = ДополнительныеОтчетыИОбработки.СведенияОВнешнейОбработке();
ПараметрыРегистрации.Вид = ДополнительныеОтчетыИОбработкиКлиентСервер.ВидОбработкиДополнительнаяОбработка();
ПараметрыРегистрации.Наименование = "Дополнительная обработка";
ПараметрыРегистрации.Версия = "1.0";

НоваяКоманда = ПараметрыРегистрации.Команды.Добавить();
НоваяКоманда.Представление = "Выполнить обработку команды";
НоваяКоманда.Идентификатор = "ВыполнитьОбработкуКоманды";
НоваяКоманда .Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыВызовСерверногоМетода();

Возврат ПараметрыРегистрации;

КонецФункции // ()

Процедура ВыполнитьКоманду(ИдентификаторКоманды) Экспорт

Выполнить ИдентификаторКоманды + "()";

КонецПроцедуры

Процедура ВыполнитьОбработкуКоманды()

КонецПроцедуры

Код обработки: https://bitbucket.org/snippets/ayvas/aeX6yk

Категории:
 Программирование

Комментарии
Избранное Подписка Сортировка: Древо
1. frkbvfnjh 557 01.07.19 08:59 Сейчас в теме
1C Предприятие. Разработка и регистрация внешней дополнительной обработки. Где? Это механизм всех типовых конфигураций на базе БСП или что? Для каких конфигураций актуально? Надо бы об это говорить в самом начале
2. gosizo 33 02.07.19 16:06 Сейчас в теме
вроде и так про это немало написано, но лучше больше чем ничего
3. dsdred 1218 07.07.19 12:21 Сейчас в теме
По моему лучше за 10 минут прочитать вот эту статью https://infostart.ru/public/827126/
При чем информации в статье будет больше...
4. rozer 259 10.07.19 10:41 Сейчас в теме
"давай вася давай братан, спой нам про БСП и внешние обработки там..." ))
Оставьте свое сообщение
Обучение программированию 1С 8.3. Создание внешнего отчета "Отчет по продажам"
Князьков Алексей. Про ТабДок или TabDoc Pro
7.Графы затрат. Встречные потоки затрат
Анализатор сложных запросов. Демонстрация загрузки данных запроса из отладчика.
Практика программирования 1С с Драконом
Пиши запросы правильно, %username%! (Часть 5)
Внешняя Компонента для 1С:Предприятие 8.3 на языке D (http://www.dlang.org)
Управление задачами Загрузка изменений из хранилища 1с
1С БСП: Свойства (ч.6: Заключение)